Frustrated

I’m thinking of shelving my Early Crusaders again.  I just can’t get over the fact that they put 13th & 14th Century Knights and foot in the Army Pack I purchased.  Just too many kettle & great helms and heater shields. I spent an irritating amount of time mixing and matching horses last night (some have caparisons) and I’m just dissatisfied. I can easily morph the army into Later Crusaders, but I really like the Dark Age style of the Early Crusaders (conical helmets with nasals, and kite shields).  So I guess I will have to get aroung to ordering the correct packs and do an early/later morph.

So I guess it’s back to my Mike’s Models Antigonos Successor army. 🙂

Advertisements

3 Comments Add yours

  1. Dan Joyce says:

    Yeah I understand your frustration that’s why I am basing my Early Crusaders around my Anglo Norman army. I purchased the pascks and have 4Kn, 4Sp, 4Bd, 2Bw,2Ps and some mercenary Byzantine Cav (Drafted from the Byzantine Army) all Troops are Kites and Full Chain.
    The Later stuff I have will be used as Richards 3rd Crusade Army. Next Project the LC Horde known as the Seljuks 🙂

  2. Athanasius says:

    Thanks for stopping by Dan. This Friday I’m going to figure out the packs I need and order them. That means I’m going to have to replace 4 elements of spear and 4 elements of knights (none of the knights I got in my pack are proper). I’m thinking of ordering enough to make an Eastern Frankish army too.

  3. Tony Aguilar says:

    I feel your pain. Note to self… NEVER order an “Army Pack”. Too many manufacturers put the wrong figs or the have the wrong look to suit me.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s